Posted by on in iDevelop | 2 comments

Yes, that’s right, if you are using WordPress 1.5.2, then stay where you are, don’t be tempted by the candy that WordPress 2.0 offers you, don’t upgrade yet, especially if you are not of a techy species, that’s a bit of friendly advice from me!! 🙂

Though there’s nothing to worry about, but still, it happens sometimes with some major software upgrades, things go messy. A few things have gone awry with this WordPress release(which is a mammoth upgrade to the core) and they can prove to be too much for the non-techy users who aren’t used to the heat of applications & websites breaking down unexpectedly. I’d say that this release of WordPress can be taken on par with a nightly build, Robert posted few important things that are broken and has striked off those which are fixed in WordPress SVN(Subversion).

So in short, wait for a fixed update before upgrading your WordPress install. I’m also holding off an upgrade here & at diGit Blog since I don’t have time to attend to any crashes etc!! 😉