Posted by on in iDevelop, iG:Syntax Hiliter, PHP, WP-Plugins | 25 comments

iG:Syntax Hiliter is not fully compatible with the new WordPress 2.0. Though the existing installations might work alright, new installs of the plugin on WordPress 2.0 may cause some problems due to the revamped user system in WordPress. The earlier user levels have been disposed off and user roles have been introduced. So the plugin will not install when activated in the plugin management page on your WordPress 2.0 install as it currently checks for the minimum user level 8 to install the plugin and edit the configuration options!! 😕

I’ll be releasing an update pretty soon for WordPress 2.0 but that will quite possibly make the plugin incompatible with the older versions, though I’m not sure, I’ll try to keep it compatible. 😉